October, 2025
Incident Updates
Wednesday, October 1st
No Incidents
Thursday, October 2nd
No Incidents
Friday, October 3rd
RESOLVED
General CDN DEGRADED
Saturday, October 4th
RESOLVED
General CDN DEGRADED
Sunday, October 5th
No Incidents
Monday, October 6th
No Incidents
Tuesday, October 7th
INVESTIGATING
Meta - WhatsApp Business API DOWN
Wednesday, October 8th
No Incidents
Thursday, October 9th
No Incidents